Google Chrome < 3.0.195.24 RCE

Medium Nessus Network Monitor Plugin ID 5193

Synopsis

The remote host contains a web browser that is vulnerable to remote code execution attacks.

Description

The version of Google Chrome installed on the remote host is earlier than 3.0.195.24. Such versions are potentially affected by a remote code execution vulnerability. The 'v8' engine usees a common 'dtoa()' implementation to parse strings into floating point numbers. An attacker, exploiting this flaw, can execute arbitrary code in the Google Chrome sandbox.

Solution

Upgrade to Google Chrome 3.0.195.24 or later.

See Also

http://googlechromereleases.blogspot.com/2009/09/stable-channel-update_30.html

Plugin Details

Severity: Medium

ID: 5193

Family: Web Clients

Published: 2009/10/01

Modified: 2016/12/10

Dependencies: 4645

Nessus ID: 41958

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2009/09/30

Vulnerability Publication Date: 2009/09/30

Reference Information

CVE: CVE-2009-0689

BID: 36565