Google Chrome < 3.0.195.24 dtoa Implementation Remote Overflow

medium Nessus Plugin ID 41958
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host contains a web browser that is affected by a buffer overflow vulnerability.

Description

The version of Google Chrome installed on the remote host is earlier than 3.0.195.24. A boundary error in the dtoa() function can lead to a buffer overflow. A remote attacker could exploit this by tricking a user into visiting a malicious web page, which could result in arbitrary code execution within the Google Chrome sandbox.

Solution

Upgrade to Google Chrome 3.0.195.24 or later.

Plugin Details

Severity: Medium

ID: 41958

File Name: google_chrome_3_0_195_24.nasl

Version: 1.13

Type: local

Agent: windows

Family: Windows

Published: 10/1/2009

Updated: 7/12/2018

Dependencies: google_chrome_installed.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 6.6

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.3

Vector: AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 9/30/2009

Vulnerability Publication Date: 9/30/2009

Reference Information

CVE: CVE-2009-0689

BID: 36565

Secunia: 36913

CWE: 119