PHP < 5.2.11 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5178

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP installed on the remote host is earlier than 5.2.11. Such versions are reportedly affected by multiple issues :

- An unspecified error occurs in certificate validation inside 'php_openssl_apply_verification_policy'.
- An unspecified input validation vulnerability affects the color index in 'imagecolortransparent()'.
- A denial-of-service vulnerability related to 'popen' when invalid modes are used. (Bug 44683)

Solution

Upgrade to PHP version 5.2.11 or later.

See Also

http://www.php.net/releases/5_2_11.php

http://news.php.net/php.internals/45597

http://www.php.net/ChangeLog-5.php#5.2.11

Plugin Details

Severity: High

ID: 5178

Family: Web Servers

Published: 2009/09/18

Updated: 2019/03/06

Dependencies: 8682

Nessus ID: 41014

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2009/09/16

Reference Information

CVE: CVE-2009-3291, CVE-2009-3292, CVE-2009-3293, CVE-2009-3294, CVE-2009-4018, CVE-2009-5016

BID: 36449, 44889