PHP < 5.2.11 Multiple Vulnerabilities

High Nessus Plugin ID 41014

Synopsis

The remote web server uses a version of PHP that is affected by multiple flaws.

Description

According to its banner, the version of PHP installed on the remote host is older than 5.2.11. Such versions may be affected by several security issues :

- An unspecified error occurs in certificate validation inside 'php_openssl_apply_verification_policy'.

- An unspecified input validation vulnerability affects the color index in 'imagecolortransparent()'.

- An unspecified input validation vulnerability affects exif processing.

- Calling 'popen()' with an invalid mode can cause a crash under Windows. (Bug #44683)

- An integer overflow in 'xml_utf8_decode()' can make it easier to bypass cross-site scripting and SQL injection protection mechanisms using a specially crafted string with a long UTF-8 encoding. (Bug #49687)

- 'proc_open()' can bypass 'safe_mode_protected_env_vars'.
(Bug #49026)

Solution

Upgrade to PHP version 5.2.11 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.2.11

http://www.php.net/releases/5_2_11.php

http://news.php.net/php.internals/45597

http://www.php.net/ChangeLog-5.php#5.2.11

Plugin Details

Severity: High

ID: 41014

File Name: php_5_2_11.nasl

Version: 1.18

Type: remote

Family: CGI abuses

Published: 2009/09/18

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2009/09/16

Reference Information

CVE: CVE-2009-3291, CVE-2009-3292, CVE-2009-3293, CVE-2009-3294, CVE-2009-4018, CVE-2009-5016

BID: 36449, 44889

Secunia: 36791

CWE: 20, 134, 264