OpenOffice < 3.1.1 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5145


The remote host has a program that is vulnerable to multiple attack vectors.


The version of OpenOffice is earlier than 3.1.1. Such versions are potentially affected by several issues :

- A boundary error when parsing certain records can be exploited to cause a heap-based buffer overflow via a specially crafted document. (CVE-2009-0201)

- An integer underflow error when parsing certain records in the document table. (CVE-2009-0200)

- A vulnerability in the parser of EMFS files can lead to the execution of arbitrary commands. (CVE-2009-2139)


Upgrade to OpenOffice version 3.1.1 or later.

See Also

Plugin Details

Severity: Medium

ID: 5145

Family: Generic

Published: 2009/09/01

Modified: 2016/01/22

Nessus ID: 40826

Risk Information

Risk Factor: Medium


Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:ND


Base Score: 5.6

Temporal Score: 5.2


Temporal Vector: CVSS3#E:F/RL:O/RC:X

Vulnerability Information

Patch Publication Date: 2009/08/31

Vulnerability Publication Date: 2009/09/01

Reference Information

CVE: CVE-2009-2139, CVE-2009-0200, CVE-2009-0201

BID: 36200, 36291