OpenOffice < 3.1.1 Multiple Buffer Overflows

High Nessus Plugin ID 40826


The remote Windows host has a program affected by multiple buffer overflows.


The version of OpenOffice installed on the remote host is earlier than 3.1.1. Such versions are affected by several issues :

- Parsing certain records in a document table could lead to heap-based overflows and arbitrary code execution. (CVE-2009-0200)

- Parsing certain records in specially crafted files could lead to heap-based overflows and arbitrary code execution. (CVE-2009-0201)


Upgrade to OpenOffice version 3.1.1 or later.

See Also

Plugin Details

Severity: High

ID: 40826

File Name: openoffice_311.nasl

Version: $Revision: 1.10 $

Type: local

Agent: windows

Family: Windows

Published: 2009/09/01

Modified: 2016/12/07

Dependencies: 25551

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 8.1

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:ND/RL:OF/RC:ND

Vulnerability Information

CPE: cpe:/

Required KB Items: SMB/OpenOffice/Build

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2009/08/31

Vulnerability Publication Date: 2009/09/01

Reference Information

CVE: CVE-2009-0200, CVE-2009-0201

BID: 36200

OSVDB: 57658, 57659

Secunia: 35036

CWE: 119, 189