Apache < 2.2.12 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5111

Synopsis

The remote web server may be affected by several issues.

Description

According to its banner, the version of Apache 2.2 installed on the remote host is older than 2.2.12. Such versions may be affected by several issues :

- A denial-of-service vulnerability in the 'mod_proxy' module could be exploited to cause the process to consume large amounts of CPU resources. (CVE-2009-1890)

- The 'mod_deflate' module is prone to a remote denial-of-service vulnerability when large file downloads are terminated before completing. (CVE-2009-1891)

PVS cannot determine whether the affected modules are in use.

Solution

Either ensure that the affected modules are not in use or upgrade to Apache version 2.2.12 or later.

See Also

https://archive.apache.org/dist/httpd/CHANGES_2.2.12

Plugin Details

Severity: Medium

ID: 5111

Family: Web Servers

Published: 2009/08/03

Modified: 2016/11/23

Dependencies: 3057

Nessus ID: 40467

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.0

Patch Publication Date: 2009/07/23

Vulnerability Publication Date: 2009/07/03

Reference Information

CVE: CVE-2009-0023, CVE-2009-1191, CVE-2009-1195, CVE-2009-1890, CVE-2009-1891, CVE-2009-1955, CVE-2009-1956

BID: 34663, 35115, 35221, 35251, 35253, 35565, 35623