Safari < 4.0.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5094

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The version of Safari installed on the remote host is earlier than 4.0.2. Such versions are potentially affected by two issues :

- A vulnerability in WebKit's handling of parent and top objects may allow for cross-site scripting attacks. (CVE-2009-1724)

- A memory corruption in WebKit's handling of numeric character references could lead to a crash or arbitrary code execution. (CVE-2009-1725)

Solution

Upgrade to Safari 4.0.2 or later.

See Also

http://support.apple.com/kb/HT3666

Plugin Details

Severity: Medium

ID: 5094

Family: Web Clients

Published: 2004/08/18

Modified: 2016/01/19

Dependencies: 3705

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Reference Information

CVE: CVE-2009-1724, CVE-2009-1725

BID: 35607, 35441