Safari < 4.0.2 Multiple Vulnerabilities

High Nessus Plugin ID 39767


The remote host contains a web browser that is affected by several vulnerabilities.


The version of Safari installed on the remote Windows host is earlier than 4.0.2. Such versions are potentially affected by two issues :

- A vulnerability in WebKit's handling of parent and top objects may allow for cross-site scripting attacks.

- A memory corruption issue in WebKit's handling of numeric character references could lead to a crash or arbitrary code execution. (CVE-2009-1725)


Upgrade to Safari 4.0.2 or later.

See Also

Plugin Details

Severity: High

ID: 39767

File Name: safari_4_0_2.nasl

Version: $Revision: 1.11 $

Type: local

Agent: windows

Family: Windows

Published: 2009/07/09

Modified: 2016/12/14

Dependencies: 31788

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 6.9

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:safari

Required KB Items: SMB/Safari/FileVersion

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2009/07/08

Reference Information

CVE: CVE-2009-1724, CVE-2009-1725

BID: 35441, 35607

OSVDB: 55738, 55739

CWE: 79, 189