Google Chrome < 2.0.172.33 Buffer Overflow vulnerability

Medium Nessus Network Monitor Plugin ID 5082

Synopsis

The remote host contains a web browser that is vulnerable to a buffer overflow attack.

Description

The version of Google Chrome installed on the remote host is earlier than 2.0.172.33. Such versions are reportedly affected by a buffer overflow vulnerability when handling certain responses from HTTP servers. An attacker could exploit this issue to cause a denial of service, or execute arbitrary code with the privileges of the logged on user.

Solution

Upgrade to Google Chrome 2.0.172.33 or later.

See Also

http://googlechromereleases.blogspot.com/2009/06/stable-beta-update-security-fix.html

Plugin Details

Severity: Medium

ID: 5082

File Name: 5082.prm

Family: Web Clients

Published: 2004/08/18

Modified: 2016/11/23

Dependencies: 4645

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Reference Information

CVE: CVE-2009-2121

BID: 35462, 35463

OSVDB: 55278