PHP 5.x < 5.2.10 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5080

Synopsis

The remote web server uses a version of PHP that is affected by multiple vulnerabilities.

Description

According to its banner, the version of PHP 5.x installed on the remote host is earlier than 5.2.10. Such versions are reportedly affected by multiple vulnerabilities :

- A restriction-bypass vulnerability could allow the execution of arbitrary commands when 'safe_mode' is enabled 'safe_mode_exec_dir' is not set. This issue only affects PHP on Windows. (bug 45997)

- A denial of service vulnerability is triggered when an application processes a 'JPEG' image file through a call to the 'exif_read_data()' function. (bug 48378).

Solution

Upgrade to PHP version 5.2.10 or later.

See Also

http://www.php.net/ChangeLog-5.php#5.2.10

Plugin Details

Severity: High

ID: 5080

Family: Web Servers

Published: 2009/06/20

Modified: 2016/11/23

Dependencies: 8682

Nessus ID: 39480

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2009/06/18

Vulnerability Publication Date: 2009/06/18

Reference Information

CVE: CVE-2009-2687

BID: 35440, 35435