PHP < 5.2.10 Multiple Vulnerabilities

Medium Nessus Plugin ID 39480


The remote web server uses a version of PHP that is affected by multiple vulnerabilities.


According to its banner, the version of PHP installed on the remote host is older than 5.2.10. Such versions are reportedly affected by multiple vulnerabilities :

- Sufficient checks are not performed on fields reserved for offsets in function 'exif_read_data()'. Successful exploitation of this issue could result in a denial of service condition. (bug 48378)

- Provided 'safe_mode_exec_dir' is not set (not set by default), it may be possible to bypass 'safe_mode' restrictions by preceding a backslash in functions such as 'exec()', 'system()', 'shell_exec()', 'passthru()' and 'popen()' on a system running PHP on Windows. (bug 45997)


Upgrade to PHP version 5.2.10 or later.

See Also

Plugin Details

Severity: Medium

ID: 39480

File Name: php_5_2_10.nasl

Version: 1.12

Type: remote

Family: CGI abuses

Published: 2009/06/22

Updated: 2018/11/15

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.1

Temporal Score: 3.8

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2009/06/18

Vulnerability Publication Date: 2009/05/24

Reference Information

CVE: CVE-2009-2687

BID: 35440, 35435

Secunia: 35441

CWE: 20