Apache Tomcat 4.1.x < 4.1.40 / 5.5.x < 5.5.28 / 6.0.x < 6.0.20 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 5044
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote Apache Tomcat server is affected by multiple vulnerabilities.


According to its self-reported version number, the Apache Tomcat server listening on the remote host is prior to 4.1.40, 5.5.28, or 6.0.20. It is, therefore, affected by the following vulnerabilities:

- The remote server is affected by a directory traversal vulnerability if a RequestDispatcher obtained from a Request object is used. A specially crafted value for a request parameter can be used to access potentially sensitive configuration files or other files, e.g., files in the WEB-INF directory. (CVE-2008-5515)

- The remote server is affected by a denial of service vulnerability if configured to use the Java AJP connector. An attacker can send a malicious request with invalid headers which causes the AJP connector to be put into an error state for a short time. This behavior can be used as a denial of service attack. (CVE-2009-0033)

- The remote server is affected by a username enumeration vulnerability if configured to use FORM authentication along with the 'MemoryRealm', 'DataSourceRealm', or 'JDBCRealm' authentication realms. (CVE-2009-0580)

- The remote server is affected by a script injection vulnerability if the example JSP application, 'cal2.jsp', is installed. An unauthenticated, remote attacker can exploit this issue to inject arbitrary HTML or script code into a user's browser to be executed within the security context of the affected site. (CVE-2009-0781)

- The remote server is vulnerable to unauthorized modification of 'web.xml', 'context.xml', or TLD files of arbitrary web applications. This vulnerability allows the XML parser, used to process the XML and TLD files, to be replaced. (CVE-2009-0783)

Note that Nessus Network Monitor has not tested for these issues but has instead relied only on the application's self-reported version number.


Upgrade to Apache Tomcat 4.1.40 / 5.5.28 / 6.0.20 or later.

See Also



Plugin Details

Severity: Medium

ID: 5044

Family: Web Servers

Published: 8/18/2004

Updated: 3/6/2019

Nessus ID: 46753

Risk Information


Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:tomcat:*:*:*:*:*:*:*:*

Patch Publication Date: 6/3/2009

Vulnerability Publication Date: 6/3/2009

Exploitable With

CANVAS (D2ExploitPack)

Reference Information

CVE: CVE-2009-0580, CVE-2008-5515, CVE-2009-0033, CVE-2009-0783

BID: 35193, 35196, 35263, 35416