Google Chrome < 1.0.154.64 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5020

Synopsis

The remote host contains a web browser that is vulnerable to multiple attack vectors.

Description

The version of Google Chrome installed on the remote host is earlier than 1.0.154.64. Such versions are reportedly affected by multiple vulnerabilities :

- A failure to properly validate input from a renderer (tab) process could allow an attacker to crash the browser and possibly run arbitrary code with the privileges of the logged on user. (CVE-2009-1441)

- A failure to check the result of integer multiplication when computing image sizes could allow a specially-crafted image or canvas to cause a tab to crash and possibly allow an attacker to execute arbitrary code inside the (sandboxed) renderer process. (CVE-2009-1442)

Solution

Upgrade to Google Chrome 1.0.154.64 or newer.

See Also

http://googlechromereleases.blogspot.com/2009/05/stable-update-security-fix.html

Plugin Details

Severity: Medium

ID: 5020

Family: Web Clients

Published: 2004/08/18

Modified: 2018/09/16

Dependencies: 4645

Nessus ID: 38699

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Reference Information

CVE: CVE-2009-1441, CVE-2009-1442

BID: 34859