Google Chrome < 1.0.154.64 Multiple Overflows

high Nessus Plugin ID 38699

Synopsis

The remote host contains a web browser that is affected by multiple vulnerabilities.

Description

The version of Google Chrome installed on the remote host is earlier than 1.0.154.64. Such versions are reportedly affected by multiple vulnerabilities :

- A failure to properly validate input from a renderer (tab) process could allow an attacker to crash the browser and possibly run arbitrary code with the privileges of the logged on user. (CVE-2009-1441)

- A failure to check the result of integer multiplication when computing image sizes could allow a specially crafted image or canvas to cause a tab to crash and possibly allow an attacker to execute arbitrary code inside the (sandboxed) renderer process. (CVE-2009-1442)

Solution

Upgrade to Google Chrome 1.0.154.64 or later.

See Also

http://www.nessus.org/u?5479ada5

Plugin Details

Severity: High

ID: 38699

File Name: google_chrome_1_0_154_64.nasl

Version: 1.18

Type: local

Agent: windows

Family: Windows

Published: 5/7/2009

Updated: 4/11/2022

Configuration: Enable thorough checks

Supported Sensors: Nessus Agent

Risk Information

VPR

Risk Factor: Medium

Score: 5.9

CVSS v2

Risk Factor: High

Base Score: 9.3

Temporal Score: 6.9

Vector: AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:google:chrome

Required KB Items: SMB/Google_Chrome/Installed

Exploit Ease: No known exploits are available

Patch Publication Date: 5/5/2009

Reference Information

CVE: CVE-2009-1441, CVE-2009-1442

BID: 34859

SECUNIA: 35014

CWE: 119, 189