PHP 5.x < 5.2.9 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 4943


The remote web server uses a version of PHP that is affected by multiple flaws.


According to its banner, the version of PHP 5.x installed on the remote host is older than 5.2.9. Such versions may be affected by several security issues :

- Background color is not correctly validated with a non-true color image in function 'imagerotate()'. (CVE-2008-5498)

- A denial of service condition can be triggered by trying to extract zip files that contain files with relative paths in file or directory names.

- Function 'explode()' is affected by an unspecified vulnerability.

- It may be possible to trigger a segfault by passing a specially crafted string to function 'json_decode()'.

- Function 'xml_error_string()' is affected by a flaw that results in messages being off by one." );


Upgrade to version 5.2.9 or higher.

See Also

Plugin Details

Severity: High

ID: 4943

Family: Web Servers

Published: 2009/03/02

Updated: 2019/03/06

Dependencies: 8682

Nessus ID: 35750

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2009/02/26

Vulnerability Publication Date: 2009/02/26

Reference Information

CVE: CVE-2008-5498, CVE-2009-1271, CVE-2009-1272

BID: 33002, 33927