PHP < 5.2.9 Multiple Vulnerabilities

Medium Nessus Plugin ID 35750

Synopsis

The remote web server uses a version of PHP that is affected by multiple flaws.

Description

According to its banner, the version of PHP installed on the remote host is older than 5.2.9. Such versions may be affected by several security issues :

- Background color is not correctly validated with a non true color image in function 'imagerotate()'. (CVE-2008-5498)

- A denial of service condition can be triggered by trying to extract zip files that contain files with relative paths in file or directory names.

- Function 'explode()' is affected by an unspecified vulnerability.

- It may be possible to trigger a segfault by passing a specially crafted string to function 'json_decode()'.

- Function 'xml_error_string()' is affected by a flaw which results in messages being off by one.

Solution

Upgrade to PHP version 5.2.9 or later.

See Also

http://news.php.net/php.internals/42762

http://www.php.net/releases/5_2_9.php

http://www.php.net/ChangeLog-5.php#5.2.9

Plugin Details

Severity: Medium

ID: 35750

File Name: php_5_2_9.nasl

Version: 1.13

Type: remote

Family: CGI abuses

Published: 2009/02/27

Updated: 2018/07/24

Dependencies: 48243

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Available: false

Exploit Ease: No exploit is required

Patch Publication Date: 2009/02/26

Reference Information

CVE: CVE-2008-5498, CVE-2009-1271, CVE-2009-1272

BID: 33002, 33927

Secunia: 34081

CWE: 20, 200