Samba 3.0.29 - 3.2.4 Potential Memory Disclosure

Medium Nessus Network Monitor Plugin ID 4774

Synopsis

The remote Samba server may be affected by an information disclosure vulnerability.

Description

According to its banner, the version of the Samba server on the remote host is between 3.0.29 and 3.2.4 inclusive. Such versions reportedly can potentially leak arbitrary memory contents of the 'smbd' process due to a missing bounds check on client-generated offsets of secondary 'trans', 'trans2', and 'nttrans' requests.

Solution

Upgrade to version 3.2.5 / 3.0.33 or higher or apply the appropriate patch referenced in the project's advisory.

See Also

http://www.samba.org/samba/history/samba-3.0.33.html

http://www.samba.org/samba/history/samba-3.2.5.html

http://www.samba.org/samba/security/CVE-2008-4314.html

Plugin Details

Severity: Medium

ID: 4774

Family: Samba

Published: 2008/12/01

Modified: 2016/11/23

Dependencies: 8740

Nessus ID: 34993

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2008/12/01

Vulnerability Publication Date: 2008/12/01

Reference Information

CVE: CVE-2008-4314

BID: 32494