VLC Media Player < 0.9.5 TY Media File Handling Memory Curruption (deprecated)

Medium Nessus Network Monitor Plugin ID 4726

Synopsis

The remote Windows host contains an application that is affected by a memory corruption vulnerability.

Description

The version of VLC Media Player installed on the remote host is earlier than 0.9.5. Such versions do not properly parse TY media files. By sending a specially formatted TY file and tricking a user into opening the file, arbitrary code may be executed within the context of the affected application.

Solution

Upgrade to version 0.9.5 or higher.

See Also

http://www.coresecurity.com/content/vlc-xspf-memory-corruption

http://archives.neohapsis.com/archives/fulldisclosure/2008-10/0267.html

http://www.nessus.org/u?eb7b1baf

http://www.videolan.org/security/sa0809.html

Plugin Details

Severity: Medium

ID: 4726

Family: Web Clients

Published: 2008/10/27

Modified: 2016/01/19

Dependencies: 1735, 8314

Nessus ID: 34400

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:P/RL:O/RC:C

Reference Information

CVE: CVE-2008-4558

BID: 31758