VLC Media Player < 0.9.3 XSPF Playlist Handling Memory Corruption

High Nessus Plugin ID 34400


The remote Windows host contains an application that is affected by a memory corruption vulnerability.


The version of VLC media player installed on the remote host is earlier than 0.9.3. Such versions do not properly bounds-check an identifier tag in XSPF files in the 'demux/playlist/xspf.c' library before using it to index into an array on the heap. By tricking a user into opening a malicious XSPF file, it may be possible to execute arbitrary code within the context of the affected application.


Upgrade to VLC Media Player version 0.9.4 or later (there are no official binaries for Windows of version 0.9.3).

See Also




Plugin Details

Severity: High

ID: 34400

File Name: vlc_0_9_3.nasl

Version: $Revision: 1.9 $

Type: local

Agent: windows

Family: Windows

Published: 2008/10/15

Modified: 2016/11/03

Dependencies: 31852

Risk Information

Risk Factor: High


Base Score: 9.3

Temporal Score: 7.3

Vector: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:videolan:vlc_media_player

Required KB Items: SMB/VLC/Version

Exploit Available: true

Exploit Ease: Exploits are available

Reference Information

CVE: CVE-2008-4558

BID: 31758

OSVDB: 49112

CWE: 399