CUPS < 1.3.9 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 4707


The remote printer service is affected by multiple vulnerabilities.


According to its banner, the version of CUPS installed on the remote host is earlier than 1.3.9. Such versions are affected by several issues :

- The HP-GL/2 filter does not adequately check the ranges on the pen width and pen color opcodes, which allows an attacker to overwrite memory addresses with arbitrary data and which may result in execution of arbitrary code (STR #2911).
- There is a heap-based buffer overflow in the SGI file format parsing module that can be triggered with malformed Run Length Encoded (RLE) data to execute arbitrary code (STR #2918).
- There is an integer overflow vulnerability in the 'WriteProlog()' function in the 'texttops' application that can be triggered when calculating the page size used for storing PostScript data to execute arbitrary code (STR #2919).


Upgrade to version 1.3.9 or higher.

See Also

Plugin Details

Severity: High

ID: 4707

File Name: 4707.prm

Family: Web Servers

Published: 2008/10/13

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 34385

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.8


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Exploitable With

Core Impact

Reference Information

CVE: CVE-2008-3639, CVE-2008-3640, CVE-2008-3641

BID: 31688, 31690

OSVDB: 49131, 49132