CUPS < 1.3.9 Multiple Vulnerabilities

High Nessus Plugin ID 34385


The remote printer service is affected by multiple vulnerabilities.


According to its banner, the version of CUPS installed on the remote host is earlier than 1.3.9. Such versions are affected by several issues :

- The HP-GL/2 filter does not adequately check the ranges on the pen width and pen color opcodes that allows an attacker to overwrite memory addresses with arbitrary data, which may result in execution of arbitrary code (STR #2911).

- There is a heap-based buffer overflow in the SGI file format parsing module that can be triggered with malformed Run Length Encoded (RLE) data to execute arbitrary code (STR #2918).

- There is an integer overflow vulnerability in the 'WriteProlog()' function in the 'texttops' application that can be triggered when calculating the page size used for storing PostScript data to execute arbitrary code (STR #2919).


Upgrade to CUPS version 1.3.9 or later.

See Also

Plugin Details

Severity: High

ID: 34385

File Name: cups_1_3_9.nasl

Version: $Revision: 1.20 $

Type: remote

Family: Misc.

Published: 2008/10/10

Modified: 2016/11/17

Dependencies: 10107, 29727

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:apple:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Available: true

Exploit Ease: Exploits are available

Exploitable With

Core Impact

Reference Information

CVE: CVE-2008-3639, CVE-2008-3640, CVE-2008-3641

BID: 31688, 31690

OSVDB: 49130, 49131, 49132

Secunia: 32226

CWE: 119, 189, 399