CUPS < 1.3.7 Multiple Vulnerabilities

low Nessus Network Monitor Plugin ID 4456
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote printer service is affected by multiple vulnerabilities.

Description

According to its banner, the version of CUPS installed on the remote host is affected by several issues :

- A buffer overflow in 'cgiCompileSearch' that can lead to arbitrary code execution (STR #2729).
- A GIF image filter overflow involving 'code_size' value from a user-supplied GIF image used in 'gif_read_lzw' (STR #2765).
- A temporary file with Samba credentials may be left behind by cupsaddsmb if no Windows drivers were installed (STR #2779).

Solution

Upgrade to version 1.3.7 or higher.

See Also

http://www.cups.org/str.php?L2729

http://www.cups.org/str.php?L2765

http://www.cups.org/str.php?L2779

http://www.cups.org/articles.php?L537

http://www.cups.org

Plugin Details

Severity: Low

ID: 4456

Family: Web Servers

Published: 4/3/2008

Updated: 3/6/2019

Dependencies: 1442

Nessus ID: 31730

Risk Information

CVSS v2

Risk Factor: Low

Base Score: 2.6

Temporal Score: 1.9

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Low

Base Score: 3.7

Temporal Score: 3.6

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:easy_software_products:cups:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2008-1373, CVE-2008-0047

BID: 28307, 28544