CUPS < 1.3.7 Multiple Vulnerabilities

Low Nessus Plugin ID 31730


The remote printer service is affected by multiple vulnerabilities.


According to its banner, the version of CUPS installed on the remote host is affected by several issues :

- A buffer overflow exists in 'cgiCompileSearch' that could lead to arbitrary code execution (STR #2729).

- A GIF image filter overflow exists involving 'code_size' value from a user-supplied GIF image used in 'gif_read_lzw' (STR #2765).

- A temporary file with Samba credentials may be left behind by cupsaddsmb if no Windows drivers were installed (STR #2779).


Upgrade to CUPS version 1.3.7 or later.

See Also

Plugin Details

Severity: Low

ID: 31730

File Name: cups_1_3_7.nasl

Version: $Revision: 1.18 $

Type: remote

Family: Misc.

Published: 2008/04/03

Modified: 2016/05/04

Dependencies: 10107, 29727

Risk Information

Risk Factor: Low


Base Score: 2.6

Temporal Score: 2.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:cups:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2008-0047, CVE-2008-1373

BID: 28307, 28544

OSVDB: 43376, 44160, 48699

CWE: 119