CUPS < 1.3.7 Multiple Vulnerabilities

low Nessus Plugin ID 31730
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.


The remote printer service is affected by multiple vulnerabilities.


According to its banner, the version of CUPS installed on the remote host is affected by several issues :

- A buffer overflow exists in 'cgiCompileSearch' that could lead to arbitrary code execution (STR #2729).

- A GIF image filter overflow exists involving 'code_size' value from a user-supplied GIF image used in 'gif_read_lzw' (STR #2765).

- A temporary file with Samba credentials may be left behind by cupsaddsmb if no Windows drivers were installed (STR #2779).


Upgrade to CUPS version 1.3.7 or later.

See Also

Plugin Details

Severity: Low

ID: 31730

File Name: cups_1_3_7.nasl

Version: 1.19

Type: remote

Family: Misc.

Published: 4/3/2008

Updated: 7/6/2018

Dependencies: http_version.nasl, cups_1_3_5.nasl

Configuration: Enable paranoid mode

Risk Information


Risk Factor: Medium

Score: 5.9


Risk Factor: Low

Base Score: 2.6

Temporal Score: 1.9

Vector: AV:N/AC:H/Au:N/C:N/I:N/A:P

Temporal Vector: E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:cups:cups

Required KB Items: www/cups, Settings/ParanoidReport

Exploit Ease: No known exploits are available

Reference Information

CVE: CVE-2008-0047, CVE-2008-1373

BID: 28307, 28544

CWE: 119