PHP 4.x < 4.4.8 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 4331


The remote web server uses a version of PHP that is affected by multiple issues.


According to its banner, the version of PHP 4.x installed on the remote host is older than 4.4.8. Such versions may be affected by several issues, including integer overflows involving the 'chunk_split', 'strcspn', and 'strspn' functions, and 'safe_mode' / 'open_basedir' bypasses.


Upgrade to version 4.4.8 or higher.

See Also

Plugin Details

Severity: Medium

ID: 4331

Family: Web Servers

Published: 4/10/2015

Updated: 3/6/2019

Nessus ID: 29833

Risk Information


Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 1/3/2008

Vulnerability Publication Date: 8/30/2007

Reference Information

CVE: CVE-2007-3378, CVE-2008-0145

BID: 24661, 49631