PHP 4.x < 4.4.8 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 4331

Synopsis

The remote web server uses a version of PHP that is affected by multiple issues.

Description

According to its banner, the version of PHP 4.x installed on the remote host is older than 4.4.8. Such versions may be affected by several issues, including integer overflows involving the 'chunk_split', 'strcspn', and 'strspn' functions, and 'safe_mode' / 'open_basedir' bypasses.

Solution

Upgrade to version 4.4.8 or higher.

See Also

http://www.php.net/releases/4_4_8.php

Plugin Details

Severity: Medium

ID: 4331

File Name: 4331.prm

Family: Web Servers

Published: 2015/04/10

Modified: 2016/11/23

Dependencies: 8728

Nessus ID: 29833

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2008/01/03

Vulnerability Publication Date: 2007/08/30

Reference Information

CVE: CVE-2007-3378, CVE-2008-0145

BID: 24661, 49631

OSVDB: 36869, 41774