PHP < 4.4.8 Multiple Vulnerabilities

high Nessus Plugin ID 29833


The remote web server uses a version of PHP that is affected by multiple issues.


According to its banner, the version of PHP installed on the remote host is older than 4.4.8. Such versions may be affected by several issues, including integer overflows involving the 'chunk_split', 'strcspn', and 'strspn' functions, and 'safe_mode' / 'open_basedir' bypasses.


Upgrade to PHP version 4.4.8 or later.

See Also

Plugin Details

Severity: High

ID: 29833

File Name: php_4_4_8.nasl

Version: 1.22

Type: remote

Family: CGI abuses

Published: 1/3/2008

Updated: 4/11/2022

Configuration: Enable thorough checks

Risk Information


Risk Factor: Medium

Score: 6.6


Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Required KB Items: www/PHP

Exploit Ease: No exploit is required

Patch Publication Date: 1/3/2008

Vulnerability Publication Date: 8/30/2007

Reference Information

CVE: CVE-2007-3378, CVE-2007-3799, CVE-2007-3997, CVE-2007-4657, CVE-2007-4658, CVE-2008-0145, CVE-2008-2108

BID: 24661, 49631

CWE: 20, 119, 189, 264