OpenSSL < 0.9.8f Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 4221

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is using a version of OpenSSL that is older than 0.9.7n or 0.9.8f. There are several bugs in this version of OpenSSL that may allow an attacker to either execute remote code or cause a Denial of Service (DoS).

Solution

Upgrade to version 0.9.8f or higher.

See Also

http://www.securityfocus.com/archive/1/[email protected]

Plugin Details

Severity: Medium

ID: 4221

Family: Web Servers

Published: 2007/10/01

Modified: 2016/01/21

Dependencies: 5563

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Reference Information

CVE: CVE-2007-4995, CVE-2007-5135

BID: 26055, 25831