Lighttpd < 1.4.18 mod_fastcgi HTTP Request Header Overflow

Medium Nessus Network Monitor Plugin ID 4206

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running Lighttpd, a small web server. This version of Lighttpd is vulnerable to a buffer overflow via the 'mod_fastcgi' module. An attacker exploiting this flaw would only need the ability to send large, malformed requests to the 'mod_fastcgi' module. Successful exploitation would result in the attacker executing arbitrary code.

Solution

Upgrade to 1.4.18 or higher.

See Also

http://www.lighttpd.net

Plugin Details

Severity: Medium

ID: 4206

File Name: 4206.prm

Family: Web Servers

Published: 2007/09/10

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Exploitable With

CANVAS (D2ExploitPack)

Core Impact

Reference Information

CVE: CVE-2007-4727

BID: 25622