lighttpd mod_fastcgi HTTP Request Header Remote Overflow

Medium Nessus Plugin ID 26057


The remote web server is affected by a buffer overflow vulnerability.


The remote web server appears to be lighttpd running with the FastCGI module (mod_fastcgi). The version of the FastCGI module on the remote host is affected by a buffer overflow vulnerability. A remote attacker can exploit this, by sending a specially crafted request with a long header, to add or replace headers passed to PHP, such as SCRIPT_FILENAME, which in turn could result in arbitrary code execution.


Upgrade to lighttpd version 1.4.18 or later. Alternatively, disable the FastCGI module.

See Also

Plugin Details

Severity: Medium

ID: 26057

File Name: lighttpd_fastcgi_overflow.nasl

Version: 1.20

Type: remote

Family: Web Servers

Published: 2007/09/17

Updated: 2018/07/13

Dependencies: 106628

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:lighttpd:lighttpd

Required KB Items: installed_sw/lighttpd, www/php

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2007/09/10

Exploitable With

CANVAS (D2ExploitPack)

Core Impact

Reference Information

CVE: CVE-2007-4727

BID: 25622

CWE: 119