Samba < 3.0.25 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 3990

Synopsis

The remote Samba server is affected by multiple vulnerabilities.

Description

According to its banner, the version of the Samba server installed on the remote host is affected by multiple buffer overflow and remote command injection vulnerabilities that can be exploited remotely, as well as a local privilege escalation bug.

Solution

Upgrade to version 3.0.25 or higher.

See Also

http://www.samba.org/samba/security/CVE-2007-2446.html

http://www.samba.org/samba/security/CVE-2007-2447.html

http://www.samba.org/samba/security/CVE-2007-2444.html

Plugin Details

Severity: High

ID: 3990

File Name: 3990.prm

Family: Samba

Published: 2007/05/16

Modified: 2016/01/15

Dependencies: 8740

Nessus ID: 25217

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2007/05/14

Vulnerability Publication Date: 2007/05/14

Exploitable With

CANVAS (CANVAS)

Core Impact

Metasploit (Samba "username map script" Command Execution)

Reference Information

CVE: CVE-2007-2444, CVE-2007-2446, CVE-2007-2447

BID: 23972, 23973, 23974, 24195, 24196, 24197, 24198