Samba < 3.0.25 Multiple Vulnerabilities

Critical Nessus Plugin ID 25217


The remote Samba server is affected by multiple vulnerabilities.


According to its banner, the version of the Samba server installed on the remote host is affected by multiple buffer overflow and remote command injection vulnerabilities, which can be exploited remotely, as well as a local privilege escalation bug.


Upgrade to Samba version 3.0.25 or later.

See Also

Plugin Details

Severity: Critical

ID: 25217

File Name: samba_3_0_25.nasl

Version: $Revision: 1.17 $

Type: remote

Family: Misc.

Published: 2007/05/15

Modified: 2016/05/13

Dependencies: 10785

Risk Information

Risk Factor: Critical


Base Score: 10

Temporal Score: 9.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:ND/RC:ND

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: Settings/ParanoidReport, SMB/NativeLanManager

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2007/07/11

Vulnerability Publication Date: 2007/05/14

Exploitable With


Core Impact

Metasploit (Samba "username map script" Command Execution)

Reference Information

CVE: CVE-2007-2444, CVE-2007-2446, CVE-2007-2447

BID: 23972, 23973, 23974, 24195, 24196, 24197, 24198

OSVDB: 34698, 34699, 34700, 34731, 34732, 34733