OpenSSL < 0.9.7l / 0.9.8d Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3755


The remote host is vulnerable to multiple attack vectors.


The remote host is using a version of OpenSSL that is older than 0.9.6m or 0.9.7d There are several bugs in this version of OpenSSL that may allow an attacker to either execute remote code or cause a Denial of Service (DoS).


Upgrade to version 0.9.7l, 0.9.8d or higher.

See Also

Plugin Details

Severity: Medium

ID: 3755

Family: Web Servers

Published: 2006/09/28

Updated: 2019/03/06

Dependencies: 5563

Nessus ID: 17757

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5.8

Temporal Score: 4.3

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 6.3

Temporal Score: 5.5

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Reference Information

CVE: CVE-2006-2940, CVE-2006-2937, CVE-2006-3738

BID: 20249, 20248, 20247