OpenSSL < 0.9.7l / 0.9.8d Multiple Vulnerabilities

Critical Nessus Plugin ID 17757

New! Vulnerability Priority Rating (VPR)

Tenable calculates a dynamic VPR for every vulnerability. VPR combines vulnerability information with threat intelligence and machine learning algorithms to predict which vulnerabilities are most likely to be exploited in attacks. Read more about what VPR is and how it's different from CVSS.

VPR Score: 5.9


The remote server is affected by multiple vulnerabilities.


According to its banner, the remote server is running a version of OpenSSL that is earlier than 0.9.7l or 0.9.8d. As such, it is affected by multiple vulnerabilities :

- A remote attacker could trigger a denial of service, either via malformed ASN.1 structures or specially crafted public keys. (CVE-2006-2937, CVE-2006-3738)

- A remote attacker could execute arbitrary code on the remote server by exploiting a buffer overflow in the SSL_get_shared_ciphers function. (CVE-2006-2940)

- A remote attacker could crash a client by sending an invalid server Hello. (CVE-2006-4343)


Upgrade to OpenSSL 0.9.7l / 0.9.8d or later.

See Also

Plugin Details

Severity: Critical

ID: 17757

File Name: openssl_0_9_7l_0_9_8d.nasl

Version: 1.11

Type: remote

Family: Web Servers

Published: 2012/01/04

Updated: 2018/11/15

Dependencies: 57323

Risk Information

Risk Factor: Critical

VPR Score: 5.9

CVSS v2.0

Base Score: 10

Temporal Score: 7.8

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:openssl:openssl

Required KB Items: openssl/port

Exploit Available: true

Exploit Ease: Exploits are available

Patch Publication Date: 2006/09/28

Vulnerability Publication Date: 2006/09/28

Reference Information

CVE: CVE-2006-2937, CVE-2006-3738, CVE-2006-2940, CVE-2006-4343

BID: 20247, 20248, 20249

CWE: 119, 399