PHP 4.x < 4.4.4 / 5.x < 5.1.4 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3732

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of PHP that is older than 4.4.4 or 5.1.5. This version is reported vulnerable to several flaws that may allow an attacker with the right to execute PHP scripts the ability to execute arbitrary code. Executed code would be run with the permissions of the web server process.

Solution

Upgrade to version 4.4.4, 5.1.5 or higher.

See Also

http://bugs.php.net/38112

http://php.net/ChangeLog-4.php

http://php.net/ChangeLog-5.php

Plugin Details

Severity: Medium

ID: 3732

File Name: 3732.prm

Family: Web Servers

Published: 2006/10/12

Modified: 2016/02/05

Dependencies: 8728, 8682

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.6

Temporal Score: 3.4

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.9

Temporal Score: 5.1

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php:php

Patch Publication Date: 2006/08/17

Vulnerability Publication Date: 2006/08/17

Reference Information

CVE: CVE-2006-4481, CVE-2006-4482, CVE-2006-4483, CVE-2006-4484, CVE-2006-4485, CVE-2006-4486

BID: 19582