Samba 4.0.x < 4.0.18 / 4.1.x < 4.1.8 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3540


The remote version of Samba is outdated and thus affected by several vulnerabilities.


Versions of Samba older than 4.0.18 or 4.1.8 are unpatched for the following vulnerabilities:

- An error in the 'dns_process_send()' function in the internal DNS server can cause an infinite loop that results in denial of service, due to the server not checking the 'reply' flag in a DNS packet header when processing a request. (CVE-2014-0239)

- A flaw in the 'vfswrap_fsctl()' function that is triggered when responding to authenticated FSCTL_GET_SHADOW_COPY_DATA or FSCTL_SRV_ENUMERATE_SNAPSHOTS client requests can result in the exposure of eight bytes of uninitialized memory. This affects versions of Samba 3.6.6 and onward. (CVE-2014-0178)


Install the patch referenced in the project's advisory, or upgrade to 4.0.18, 4.1.8, or later.

See Also

Plugin Details

Severity: Medium

ID: 3540

Family: Samba

Published: 2014/06/09

Updated: 2019/03/06

Dependencies: 8741

Nessus ID: 74242

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSS v3.0

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:X/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Patch Publication Date: 2014/05/28

Vulnerability Publication Date: 2014/05/28

Reference Information

CVE: CVE-2014-0239, CVE-2014-0178

BID: 67691, 67686