Samba 4.x < 4.0.18 Multiple Vulnerabilities

Medium Nessus Plugin ID 74242


The remote Samba server is potentially affected by multiple vulnerabilities.


According to its banner, the version of Samba running on the remote host is 4.x prior to 4.0.18 and is, therefore, potentially affected by the following vulnerabilities :

- An error exists related to 'GET_SHADOW_COPY_DATA' or 'FSCTL_SRV_ENUMERATE_SNAPSHOTS' request handling and 'vfs objects' parameter configurations of 'shadow_copy' or 'shadow_copy2' that could allow disclosure of uninitialized memory contents. (CVE-2014-0178)

- An error exists related to handling the 'reply' flag DNS packet headers that could allow denial of service attacks. (CVE-2014-0239)

Note that Nessus has relied only on the self-reported version number and has not actually tried to exploit these issues or determine if the associated patch has been applied.


Either install the patch referenced in the project's advisory, or upgrade to 4.0.18 or later.

Alternatively, refer to the vendor advisories and apply the suggested workarounds.

See Also

Plugin Details

Severity: Medium

ID: 74242

File Name: samba_4_0_18.nasl

Version: $Revision: 1.6 $

Type: remote

Family: Misc.

Published: 2014/05/30

Modified: 2016/06/16

Dependencies: 10785

Risk Information

Risk Factor: Medium


Base Score: 5

Temporal Score: 4.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:samba:samba

Required KB Items: SMB/NativeLanManager, SMB/samba, Settings/ParanoidReport

Exploit Available: false

Exploit Ease: No known exploits are available

Patch Publication Date: 2014/05/27

Vulnerability Publication Date: 2014/05/20

Reference Information

CVE: CVE-2014-0178, CVE-2014-0239

BID: 67686, 67691

OSVDB: 107484, 107485