PHP 5.1.x < 5.1.4 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 3509
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a flaw that allows local attackers to execute arbitrary commands.

Description

The remote host is running a version of PHP that is older than 5.1.4. This version is reported vulnerable to several flaws that may allow an attacker, with the right to execute PHP scripts, the ability to execute arbitrary code. Executed code would be run with the permissions of the web server process.

Solution

Upgrade to version 5.1.4 or higher.

See Also

http://www.nessus.org/u?ccaf872d

Plugin Details

Severity: Medium

ID: 3509

Family: Web Servers

Published: 10/12/2006

Updated: 3/6/2019

Dependencies: 8682

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:A/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5

Temporal Score: 4.4

Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 6/15/2006

Vulnerability Publication Date: 6/15/2006

Reference Information

CVE: CVE-2006-1494, CVE-2006-1990, CVE-2006-3017, CVE-2006-3016, CVE-2006-1608, CVE-2006-3018

BID: 17843, 17439