PHP 5.1.x < 5.1.4 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 3509


The remote host is vulnerable to a flaw that allows local attackers to execute arbitrary commands.


The remote host is running a version of PHP that is older than 5.1.4. This version is reported vulnerable to several flaws that may allow an attacker, with the right to execute PHP scripts, the ability to execute arbitrary code. Executed code would be run with the permissions of the web server process.


Upgrade to version 5.1.4 or higher.

See Also

Plugin Details

Severity: Medium

ID: 3509

Family: Web Servers

Published: 10/12/2006

Updated: 3/6/2019

Dependencies: 8682

Risk Information

Risk Factor: Medium

CVSS v2.0

Base Score: 4.3

Temporal Score: 3.2

Vector: CVSS2#AV:A/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3.0

Base Score: 5

Temporal Score: 4.4

Vector: CVSS:3.0/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:php:php:*:*:*:*:*:*:*:*

Patch Publication Date: 6/15/2006

Vulnerability Publication Date: 6/15/2006

Reference Information

CVE: CVE-2006-1494, CVE-2006-1990, CVE-2006-3017, CVE-2006-3016, CVE-2006-1608, CVE-2006-3018

BID: 17843, 17439