Apache HTTP Request Parsing HTML Injection

high Nessus Network Monitor Plugin ID 3042
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a flaw in the way that it parses HTTP requests.

Description

The remote host appears to be running a version of Apache, an open source web server. This version of Apache is vulnerable to a flaw in the way that it handles malformed HTTP requests. An attacker exploiting this flaw would be able to possibly corrupt cache memory or inject HTML requests to a vulnerable Apache server. The vulnerability stems from a non-conformance to RFC 2616 that states that HTTP requests must not include both a 'Content-Length' and 'Transfer-Encoding' field.

Solution

Upgrade to version 2.0.54, 1.3.33 or higher.

See Also

http://www.apache.org

Plugin Details

Severity: High

ID: 3042

Family: Web Servers

Published: 6/30/2005

Updated: 3/6/2019

Dependencies: 3057

Risk Information

CVSS v2

Risk Factor: High

Base Score: 8.5

Temporal Score: 7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 8.2

Temporal Score: 7.6

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2005-2088, CVE-2005-3185, CVE-2005-2491, CVE-2005-1993, CVE-2005-2969, CVE-2005-2090, CVE-2005-3701, CVE-2005-3700, CVE-2005-2757, CVE-2005-3702, CVE-2005-3705, CVE-2005-3704

BID: 13873, 15647, 14106