Apache < 2.0.50 Input Header Folding and mod_ssl DoS

medium Nessus Network Monitor Plugin ID 2744


The remote host is vulnerable to a Denial of Service (DoS) attack.


The remote host is using a version of the Apache web server that is less than 2.0.50. This version is vulnerable to two (2) remote Denial of Service (DoS) attacks. The first issue stems from a failure to properly manage memory and could lead to the consumption of massive amounts of memory and, alledgedly,a potential heap overflow. The second issue stems from mod_ssl's inability to handle sessions that terminate before any bytes of data have been sent. This second flaw results in a memory violation that leads to a loss of availability to valid users.


Upgrade to Apache 2.0.50 or higher.

See Also


Plugin Details

Severity: Medium

ID: 2744

Family: Web Servers

Published: 3/23/2005

Updated: 3/6/2019

Nessus ID: 12293

Risk Information


Risk Factor: Medium

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:apache:http_server:2.0:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2004-0493, CVE-2004-0823

BID: 12877, 10619, 11137