Apache < 2.0.50 Input Header Folding and mod_ssl DoS

Medium Nessus Network Monitor Plugin ID 2744

Synopsis

The remote host is vulnerable to a Denial of Service (DoS) attack.

Description

The remote host is using a version of the Apache web server that is less than 2.0.50. This version is vulnerable to two (2) remote Denial of Service (DoS) attacks. The first issue stems from a failure to properly manage memory and could lead to the consumption of massive amounts of memory and, alledgedly,a potential heap overflow. The second issue stems from mod_ssl's inability to handle sessions that terminate before any bytes of data have been sent. This second flaw results in a memory violation that leads to a loss of availability to valid users.

Solution

Upgrade to Apache 2.0.50 or higher.

See Also

http://www.guninski.com/httpd1.html

Plugin Details

Severity: Medium

ID: 2744

Family: Web Servers

Published: 2005/03/23

Modified: 2016/11/23

Dependencies: 3057

Nessus ID: 12293

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.0

Reference Information

CVE: CVE-2004-0823, CVE-2004-0493

BID: 11137, 10619, 12877