Apache 2.x < 2.0.50 Multiple Remote DoS

medium Nessus Plugin ID 12293


The remote web server is affected by a denial of service.


The remote host appears to be running a version of Apache 2.x that is prior to 2.0.50. It is, therefore, affected by a denial of service vulnerability that can be triggered by sending a specially crafted HTTP request, which results in the consumption of an arbitrary amount of memory. On 64-bit systems with more than 4GB virtual memory, this may lead to a heap based buffer overflow.

There is also a denial of service vulnerability in mod_ssl's 'ssl_io_filter_cleanup' function. By sending a request to a vulnerable server over SSL and closing the connection before the server can send a response, an attacker can cause a memory violation that crashes the server.


Upgrade to Apache 2.0.50 or later.

See Also


Plugin Details

Severity: Medium

ID: 12293

File Name: apache_input_header_folding_dos.nasl

Version: 1.27

Type: remote

Family: Web Servers

Published: 6/29/2004

Updated: 6/29/2018

Supported Sensors: Nessus

Risk Information


Risk Factor: Medium

Score: 6.0


Risk Factor: Medium

Base Score: 5

Temporal Score: 3.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P


Risk Factor: Medium

Base Score: 5.3

Temporal Score: 4.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS:3.0/E:P/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 6/28/2004

Reference Information

CVE: CVE-2004-0493, CVE-2004-0748

BID: 10619, 12877