Ipswitch IMail Server < 8.14.0 Delete Command Buffer Overflow

Critical Nessus Network Monitor Plugin ID 2408

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running a version of Ipswitch IMail that is older than version 8.14.0. The remote version of this software is vulnerable to a buffer overflow when it processes the argument of the 'delete' command. An attacker may exploit this flaw to execute arbitrary code on the remote host.

Solution

Upgrade to IMail 8.14.0 or higher.

Plugin Details

Severity: Critical

ID: 2408

File Name: 2408.prm

Family: Web Servers

Published: 2004/11/22

Modified: 2016/11/23

Dependencies: 1442

Risk Information

Risk Factor: Critical

CVSSv2

Base Score: 10

Temporal Score: 8.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 9.8

Temporal Score: 9.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:ipswitch:imail

Exploitable With

Metasploit (Mdaemon 8.0.3 IMAPD CRAM-MD5 Authentication Overflow)

Reference Information

CVE: CVE-2004-1520

BID: 11675