Ipswitch IMail IMAP Service DELETE Command Remote Overflow

Medium Nessus Plugin ID 15771


The remote mail server is affected by a buffer overflow vulnerability.


The remote host is running a version of Ipswitch IMail that is older than version 8.14.0.

The remote version of this software is vulnerable to a buffer overflow when it processes the argument of the 'delete' command. An attacker may exploit this flaw to execute arbitrary code on the remote host.


Upgrade to IMail 8.14 or later, as this reportedly fixes the issue.

See Also


Plugin Details

Severity: Medium

ID: 15771

File Name: ipswitch_IMail_bo2.nasl

Version: $Revision: 1.14 $

Type: remote

Agent: windows

Family: Windows

Published: 2004/11/19

Modified: 2016/10/27

Dependencies: 10107

Risk Information

Risk Factor: Medium


Base Score: 4.6

Temporal Score: 3.8

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

Vulnerability Information

CPE: cpe:/a:ipswitch:imail

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 2004/11/12

Exploitable With

Metasploit (Mdaemon 8.0.3 IMAPD CRAM-MD5 Authentication Overflow)

Reference Information

CVE: CVE-2004-1520

BID: 11675

OSVDB: 11838