Oracle MySQL < 4.0.21 Multiple Vulnerabilities (2)

high Nessus Network Monitor Plugin ID 2362

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of the MySQL database that is older than 4.0.21.

MySQL is a database that runs on both Linux/BSD and Windows platforms.
The remote version of this software is vulnerable to specially crafted ALTER TABLE SQL query that can be exploited to bypass some applied security restrictions or cause a denial of service.

To exploit this flaw, an attacker would need the ability to execute arbitrary SQL statements on the remote host.

Solution

Upgrade to version 4.0.21 or higher.

See Also

http://marc.theaimsgroup.com/?l=bugtraq&m=110140517515735&w=2

Plugin Details

Severity: High

ID: 2362

Family: Database

Published: 10/12/2004

Updated: 3/6/2019

Nessus ID: 15449

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mysql:mysql:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2004-0835, CVE-2004-0837

BID: 11357