MySQL < 3.23.59 / 4.0.21 Multiple Vulnerabilities

high Nessus Plugin ID 15449
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by multiple vulnerabilities.

Description

The remote host is running a version of the MySQL database which is older than 4.0.21 or 3.23.59.

MySQL is a database which runs on both Linux/BSD and Windows platform.
The remote version of this software is vulnerable to specially crafted 'ALTER TABLE SQL' query which can be exploited to bypass some applied security restrictions or cause a denial of service.

To exploit this flaw, an attacker would need the ability to execute arbitrary SQL statements on the remote host.

Solution

Upgrade to the latest version of MySQL 3.23.59 or 4.0.21 or newer.

See Also

http://marc.info/?l=bugtraq&m=110140517515735&w=2

Plugin Details

Severity: High

ID: 15449

File Name: mysql_multiple_flaws2.nasl

Version: 1.18

Type: remote

Family: Databases

Published: 10/11/2004

Updated: 7/16/2018

Dependencies: mysql_version.nasl

Risk Information

VPR

Risk Factor: Medium

Score: 5.5

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 5.9

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:POC/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mysql:mysql:*:*:*:*:*:*:*:*

Exploit Available: true

Exploit Ease: Exploits are available

Vulnerability Publication Date: 10/11/2004

Reference Information

CVE: CVE-2004-0835, CVE-2004-0837

BID: 11357