Oracle MySQL < 3.23.59 Multiple Vulnerabilities (2)

Medium Nessus Network Monitor Plugin ID 2361

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of the MySQL database that is older than 3.23.59.

MySQL is a database that runs on both Linux/BSD and Windows platforms.
The remote version of this software is vulnerable to specially crafted ALTER TABLE SQL query that can be exploited to bypass some applied security restrictions or cause a denial of service.

To exploit this flaw, an attacker would need the ability to execute arbitrary SQL statements on the remote host.

Solution

Upgrade to version 3.23.59 or higher.

See Also

http://marc.theaimsgroup.com/?l=bugtraq&amp;m=110140517515735&amp;w=2

Plugin Details

Severity: Medium

ID: 2361

Family: Database

Published: 2004/10/12

Modified: 2018/09/16

Dependencies: 8916

Nessus ID: 15449

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.1

Temporal Score: 5.3

Vector: CVSS2#AV:L/AC:L/Au:N/C:P/I:P/A:C

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.2

Temporal Score: 6.8

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Reference Information

CVE: CVE-2004-0837, CVE-2004-0835

BID: 11357