Oracle MySQL < 4.1.5 Bounded Parameter Overflow

Medium Nessus Network Monitor Plugin ID 2334

Synopsis

The remote host is vulnerable to an flaw that allows attackers to execute arbitrary commands.

Description

You are running a version of MySQL 4.1.x which is older than version 4.1.5. There is a flaw in the remote version of this software that may allow an attacker to execute arbitrary commands on the remote host with the privileges of the user running the mysqld process (typically 'mysql').

Solution

Upgrade to at least version 4.1.5 or higher.

See Also

http://bugs.mysql.com/bug.php?id=5194

Plugin Details

Severity: Medium

ID: 2334

File Name: 2334.prm

Family: Database

Published: 2004/09/28

Modified: 2016/01/21

Dependencies: 8915

Nessus ID: 14831

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.6

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:mysql:mysql

Reference Information

CVE: CVE-2004-2149

BID: 11261

OSVDB: 10244