MySQL libmysqlclient Prepared Statements API Overflow

medium Nessus Plugin ID 14831
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote database server is affected by a remote code execution vulnerability.

Description

You are running a version of MySQL 4.1.x, which is older than version 4.1.5.

There is a flaw in the remote version of this software that could allow an attacker to crash the affected service, thus denying access to legitimate users.

Solution

Upgrade to MySQL 4.1.5 or later, as this reportedly fixes the issue.

See Also

http://bugs.mysql.com/bug.php?id=5194

Plugin Details

Severity: Medium

ID: 14831

File Name: mysql_bounded_param_overflow.nasl

Version: 1.23

Type: remote

Family: Databases

Published: 9/27/2004

Updated: 7/16/2018

Dependencies: mysql_version.nasl, mysql_login.nasl

Configuration: Enable paranoid mode

Risk Information

VPR

Risk Factor: Low

Score: 3.6

CVSS v2

Risk Factor: Medium

Base Score: 5

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

Vulnerability Information

CPE: cpe:2.3:a:mysql:mysql:*:*:*:*:*:*:*:*

Required KB Items: Settings/ParanoidReport

Exploit Ease: No known exploits are available

Vulnerability Publication Date: 9/16/2004

Reference Information

CVE: CVE-2004-2149

BID: 11261