Apache < 2.0.52-dev 'Satisfy' Directive Access Control Bypass

High Nessus Network Monitor Plugin ID 2309

Synopsis

The remote host is vulnerable to a flaw that allows for the bypassing of authentication.

Description

The remote host is running Apache Web Server 2.0.51. It is reported that this version of Apache is vulnerable to an access control bypass attack. This issue occurs when using the 'Satisfy' directive. An attacker may gain unauthorized access to restricted resources if access control relies on this directive.

Solution

Upgrade to version 2.0.52-dev or higher.

Plugin Details

Severity: High

ID: 2309

File Name: 2309.prm

Family: Web Servers

Published: 2004/09/23

Modified: 2016/01/15

Dependencies: 3057

Nessus ID: 14803

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.0.51

Reference Information

CVE: CVE-2004-0811

BID: 11239