Apache <= 2.0.51 Satisfy Directive Access Control Bypass

High Nessus Plugin ID 14803


The remote web server is affected by an access control bypass vulnerability.


The remote host is running Apache web server 2.0.51. It is reported that this version of Apache is vulnerable to an access control bypass attack. This issue occurs when using the 'Satisfy' directive. An attacker may gain unauthorized access to restricted resources if access control relies on this directive.


Upgrade to Apache web server 2.0.52 or later.

Plugin Details

Severity: High

ID: 14803

File Name: apache_2_0_52.nasl

Version: $Revision: 1.24 $

Type: remote

Family: Web Servers

Published: 2004/09/23

Modified: 2018/01/23

Dependencies: 48204

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 7

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server

Required KB Items: installed_sw/Apache

Exploit Available: true

Exploit Ease: No exploit is required

Vulnerability Publication Date: 2004/09/23

Reference Information

CVE: CVE-2004-0811

BID: 11239

OSVDB: 10218

Secunia: 12633, 12641, 13025