Apache < 2.0.51 IPv6 Remote Buffer Overflow

Medium Nessus Network Monitor Plugin ID 2292


The remote host is vulnerable to a buffer overflow.


The remote host is running a vulnerable version of Apache. It is reported that versions prior to 2.0.51 are prone to a remote buffer overflow when parsing an URI sent over IPv6. An attacker may use this vulnerability to execute arbitrary code on the remote host or to deny service to legitimate users.


Upgrade to Apache 2.0.51 or higher.

Plugin Details

Severity: Medium

ID: 2292

Family: Web Servers

Published: 2004/09/15

Modified: 2018/09/16

Dependencies: 3057

Nessus ID: 14748

Risk Information

Risk Factor: Medium


Base Score: 5.1

Temporal Score: 5

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 5.6

Temporal Score: 4.9


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:apache:http_server:2.0

Reference Information

CVE: CVE-2004-0747, CVE-2004-0748, CVE-2004-0751, CVE-2004-0786, CVE-2004-0809

BID: 11185, 11187